HBA_LoadLibrary, HBA_FreeLibrary - load and free the resources used by the HBA Common Library
cc [ flag... ] file... -lHBAAPI [ library... ] #include <hbaapi.h> HBA_STATUS HBA_LoadLibrary(void);
HBA_STATUS HBA_FreeLibrary(void);
The HBA_LoadLibrary() function loads the Common Library, which in turn loads each VSL specified in the hba.conf(4) file.
The HBA_FreeLibrary() function releases resources held by the Common Library and each loaded VSL.
Upon successful completion, HBA_LoadLibrary() and HBA_FreeLibrary() return HBA_STATUS_OK. Otherwise, an error value is returned.
See libhbaapi(3LIB) for general error status values.
Example 1 Load the common library and each VSL.
The following example loads the common library and each VSL.
if ((status = HBA_LoadLibrary()) != HBA_STATUS_OK) { fprintf(stderr, "HBA_LoadLibrary failed: %d\n", status); return; }
See attributes(5) for descriptions of the following attributes:
|
libhbaapi(3LIB), hba.conf(4), attributes(5)
T11 FC-MI Specification
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |