getenv - return value for environment name
#include <stdlib.h> char *getenv(const char *name);
The getenv() function searches the environment list (see environ(5)) for a string of the form name=value and, if the string is present, returns a pointer to the value in the current environment.
If successful, getenv() returns a pointer to the value in the current environment; otherwise, it returns a null pointer.
The getenv() function can be safely called from a multithreaded application. Care must be exercised when using both getenv() and putenv(3C) in a multithreaded application. These functions examine and modify the environment list, which is shared by all threads in an application. The system prevents the list from being accessed simultaneously by two different threads. It does not, however, prevent two threads from successively accessing the environment list using getenv() or putenv(3C).
See attributes(5) for descriptions of the following attributes:
|
exec(2), putenv(3C), attributes(5), environ(5), standards(5)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |