libdat - direct access transport library
cc [ flag... ] file... -ldat [ library... ] #include <dat/udat.h>
The libdat library provides an application with the User Direct Access Programming Library (uDAPL) 1.2 functions to access the underlying RDMA-able interconnects. Different uDAPL service providers listed in the DAT static registry dat.conf(4) can be registered during runtime with the DAT library. After an application opens an interface adapter belonging to a particular service provider, all function calls will be redirected to that service provider's library.
The shared object libdat.so.1 provides the public interfaces defined below for applications. See Intro(3) for additional information on shared object interfaces.
dat_cno_create | dat_cno_free |
dat_cno_modify_agent | dat_cno_query |
dat_cno_wait | |
dat_cr_handoff | |
dat_cr_reject | |
dat_ep_create | |
dat_ep_dup_connect | |
dat_ep_get_status | |
dat_ep_post_rdma_read | |
dat_ep_post_recv | |
dat_ep_query | |
dat_evd_clear_unwaitable | |
dat_evd_dequeue | |
dat_evd_enable | |
dat_evd_modify_cno | |
dat_evd_query | |
dat_evd_set_unwaitable | |
dat_get_consumer_context | |
dat_ia_close | |
dat_ia_query | |
dat_lmr_free | |
dat_provider_fini | |
dat_psp_create | |
dat_psp_free | |
dat_pz_create | |
dat_pz_query | |
dat_rmr_bind | |
dat_rmr_free | |
dat_rsp_create | |
dat_rsp_query | |
dat_strerror |
dat_ep_create_with_srq | dat_ep_recv_query |
dat_ep_set_watermark | dat_lmr_sync_rdma_read |
dat_lmr_sync_rdma_write | |
dat_srq_free | |
dat_srq_query | |
dat_srq_set_lw |
The shared object libdat.so.1 also provides the public interfaces defined below for service providers.
dat_registry_add_provider | dat_registry_remove_provider |
/usr/lib/libdat.so.1
/usr/lib/64/libdat.so.1
See attributes(5) for descriptions of the following attributes:
|
datadm(1M), Intro(3), dat.conf(4), attributes(5)
The libdat library supports service providers written according to the uDAPL 1.2 specification. A service provider library has to be a dynamic loadable shared object with two public entry points exported:
dat_provider_init | dat_provider_fini |
In terms of installation, the service provider package should include a service_provider.conf(4) file. The datadm(1M) administrative configuration program should be used to add and remove service provider's entries in the system-wide dat.conf(4).
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |