locale.h, locale - category macros
#include <locale.h>
The <locale.h> header provides a definition for the lconv structure, which includes the following members. (See the definition of LC_MONETARY in locale(5).)
char *currency_symbol char *decimal_point char frac_digits char *grouping char *int_curr_symbol char int_frac_digits char int_n_cs_precedes char int_n_sep_by_space char int_n_sign_posn char int_p_cs_precedes char int_p_sep_by_space char int_p_sign_posn char *mon_decimal_point char *mon_grouping char *mon_thousands_sep char *negative_sign char n_cs_precedes char n_sep_by_space char n_sign_posn char *positive_sign char p_cs_precedes char p_sep_by_space char p_sign_posn char *thousands_sep
The <locale.h> header defines NULL (as defined in <stddef.h>) and the following as macros:
LC_ALL LC_COLLATE LC_CTYPE LC_MESSAGES LC_MONETARY LC_NUMERIC LC_TIME
The preceding expand to distinct integer constant expressions, for use as the first argument to the setlocale() function. See setlocale(3C).
Additional macro definitions, beginning with the characters LC_ and an uppercase letter, can also be specified here.
See attributes(5) for descriptions of the following attributes:
|
setlocale(3C), localeconv(3C), stddef.h(3HEAD), attributes(5), locale(5), standards(5)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |