ddi_dev_nintrs - return the number of interrupt specifications a device has
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_nintrs(dev_info_t *dip, int *resultp);
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information.
The ddi_dev_nintrs() function returns the number of interrupt specifications a device has in *resultp.
The ddi_dev_nintrs() function returns:
DDI_SUCCESS
DDI_FAILURE
The ddi_dev_nintrs() function can be called from user, interrupt, or kernel context.
See attributes(5) for descriptions of the following attributes:
|
isa(4), sbus(4), ddi_add_intr(9F), ddi_dev_nregs(9F), ddi_dev_regsize(9F), Intro(9F)
Writing Device Drivers
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |