ddi_dma_get_attr - get the device DMA attribute structure from a DMA handle
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_get_attr(ddi_dma_handle_t handle, ddi_dma_attr_t *attrp);
Solaris DDI specific (Solaris DDI). This interface is obsolete.
handle
attrp
ddi_dma_get_attr() is used to get a ddi_dma_attr(9S) structure. This structure describes the attributes of the DMA data path to which any memory object bound to the given handle will be subject.
DDI_SUCCESS
DDI_DMA_BADATTR
ddi_dma_get_attr() can be called from any context.
See attributes(5) for descriptions of the following attributes:
|
ddi_dma_alloc_handle(9F), ddi_dma_attr(9S)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |