Проверил. Как оказалось, в терминологии OSPF, BROADCAST, оказывается, и есть мультикаст, что для меня было открытием.
В общем нужно ставить non-broadcast и в секции router описывать интерфейс соседа. По поводу GRE-туннелей - поднимается без проблем. Если у вас так же не заработает - поднимайте тоннель.
Вот так работает.
R1(Fa0/0) <-> (Fa0/0)R2(Fa0/1) <-> (Fa0/1)R3R1:
interface Loopback0
ip address 10.200.200.1 255.255.255.255
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.252
ip access-group MCAST_FILTER in
ip access-group MCAST_FILTER out
ip ospf network non-broadcast
ip ospf priority 20
delay 100
duplex auto
speed auto
router ospf 1
router-id 10.200.200.1
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface FastEthernet0/0
network 172.16.0.0 0.0.0.3 area 1
neighbor 172.16.0.2
ip access-list extended MCAST_FILTER
deny ip 224.0.0.0 15.255.255.255 any
deny ip any 224.0.0.0 15.255.255.255
permit ip any any
R2:
interface Loopback0
ip address 10.200.200.2 255.255.255.255
interface Tunnel1
ip address 172.16.255.253 255.255.255.252
tunnel source 172.16.1.1
tunnel destination 172.16.1.2
tunnel key 100
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.252
ip access-group MCAST_FILTER in
ip access-group MCAST_FILTER out
ip ospf network non-broadcast
ip ospf priority 20
delay 100
duplex auto
speed auto
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.252
ip access-group MCAST_FILTER in
ip access-group MCAST_FILTER out
duplex auto
speed auto
ip access-list extended MCAST_FILTER
deny ip 224.0.0.0 15.255.255.255 any
deny ip any 224.0.0.0 15.255.255.255
permit ip any any
router ospf 1
router-id 10.200.200.2
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Tunnel1
network 172.16.0.0 0.0.0.3 area 1
network 172.16.255.252 0.0.0.3 area 1
neighbor 172.16.0.1
R3:
interface Loopback0
ip address 10.200.200.3 255.255.255.255
interface Tunnel1
ip address 172.16.255.254 255.255.255.252
tunnel source 172.16.1.2
tunnel destination 172.16.1.1
tunnel key 100
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
interface FastEthernet0/1
ip address 172.16.1.2 255.255.255.252
ip access-group MCAST_FILTER in
ip access-group MCAST_FILTER out
duplex auto
speed auto
ip access-list extended MCAST_FILTER
deny ip 224.0.0.0 15.255.255.255 any
deny ip any 224.0.0.0 15.255.255.255
permit ip any any
router ospf 1
router-id 10.200.200.3
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface Tunnel1
network 172.16.255.252 0.0.0.3 area 1
Таблицы маршрутизации:
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 3 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
O E2 172.16.1.0 [110/20] via 172.16.0.2, 00:18:49, FastEthernet0/0
O 172.16.255.252 [110/11112] via 172.16.0.2, 00:09:22, FastEthernet0/0
10.0.0.0/32 is subnetted, 3 subnets
O E2 10.200.200.2 [110/20] via 172.16.0.2, 00:20:50, FastEthernet0/0
O E2 10.200.200.3 [110/20] via 172.16.0.2, 00:08:53, FastEthernet0/0
C 10.200.200.1 is directly connected, Loopback0
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 3 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1
C 172.16.255.252 is directly connected, Tunnel1
10.0.0.0/32 is subnetted, 3 subnets
C 10.200.200.2 is directly connected, Loopback0
O E2 10.200.200.3 [110/20] via 172.16.255.254, 00:09:18, Tunnel1
O E2 10.200.200.1 [110/20] via 172.16.0.1, 00:09:28, FastEthernet0/0
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 3 subnets
O 172.16.0.0 [110/11112] via 172.16.255.253, 00:09:26, Tunnel1
C 172.16.1.0 is directly connected, FastEthernet0/1
C 172.16.255.252 is directly connected, Tunnel1
10.0.0.0/32 is subnetted, 3 subnets
O E2 10.200.200.2 [110/20] via 172.16.255.253, 00:09:26, Tunnel1
C 10.200.200.3 is directly connected, Loopback0
O E2 10.200.200.1 [110/20] via 172.16.255.253, 00:09:26, Tunnel1