enable
conf t! обозвать латиницей как хочешь
hostname my-home-router
ip domain name local
crypto key generate rsa usage mod 2048
!
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service config
no ip bootp server
!
logging buffered 65565 warnings
!
! задать свой enable секретный пароль, записать на бумажке, запомнить, бумажку сжечь
enable secret 0 my-very-good-enable-secret-word
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization console
aaa authorization exec default local
!
aaa session-id common
!
!
!
clock timezone MSK 2
! ну или где ты там живешь, имя зоны как угодно, смещение от UTC в часах
!
ip cef
ip arp proxy disable
no ip source-route
!
no ip forward-protocol nd
no ip forward-protocol udp tftp
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
!
no ip domain lookup
!
! задать пароль для пользователя vasia_admin, поменять по вкусу, записать на бумажку, запомнить, сжечь
username vasia_admin privilege 15 secret 0 vasia-secret
!
ip ssh version 2
!
! задать статический интернет адрес реальный свой
interface FastEthernet0
ip address x.x.x.x m.m.m.m
ip nat outside
!
! g.g.g.g - шлюз провайдера
ip route 0.0.0.0 0.0.0.0 g.g.g.g
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface FastEthernet4
spanning-tree portfast
!
interface FastEthernet5
spanning-tree portfast
!
interface FastEthernet6
spanning-tree portfast
!
interface FastEthernet7
spanning-tree portfast
!
interface FastEthernet8
spanning-tree portfast
!
!
! предполагаю что домашняя сеть 192.168.0.0/24
! если другая, то написаное ниже модифицировать по вкусу
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
! диапазон для вручную назначаемых адресов на всякий случай
ip dhcp excluded-address 192.168.0.0 192.168.0.127
!
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 8.8.8.8 8.8.4.4
! или операторские
domain-name local
!
ip access-list extended nat_interface
deny ip any 10.0.0.0 0.255.255.255
deny ip any 172.16.0.0 0.15.255.255
deny ip any 192.168.0.0 0.0.255.255
permit ip 192.168.0.0 0.0.0.255 any
!
ip nat inside source list nat_interface interface Fas0 overload
!
ip access-list ext vty
permit ip 192.168.0.0 0.0.0.255 any
!
line vty 0 4
access-class vty in
logging synchronous
transport input ssh
transport output all
line vty 5 15
access-class vty in
logging synchronous
exec-timeout 120 0
transport input ssh
transport output all
!
line con 0
exec-timeout 30 0
logging synchronous
!
ntp server 193.124.11.11
ntp server 194.149.67.130
ntp server 193.125.143.173
ntp server 193.125.143.172
ntp server 84.204.87.243
ntp server 80.249.135.2
ntp server 80.68.242.188
ntp server 194.87.0.20
ntp server 89.111.168.177
ntp server 194.33.191.69
ntp server 194.87.0.28
ntp server 81.200.8.213
!