Добрый день.
Прошу помочь найти проблему в данной задаче.
Необходимо увидеть все роутеры с каждой стороны.Собран стенд:
http://www.imagepost.ru/?v=644/eigrp.jpg
Конфиги:
================
R1
----------------
interface Loopback10
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.40.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
variance 2
network 10.10.10.10 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.40.0 0.0.0.3
no auto-summary
================
R2
----------------
interface Loopback20
ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.20.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
variance 2
network 20.20.20.20 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.20.0 0.0.0.3
no auto-summary
!
==================
R3
------------------
interface Loopback30
ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.30.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
variance 2
network 30.30.30.30 0.0.0.0
network 192.168.20.0 0.0.0.3
network 192.168.30.0 0.0.0.3
no auto-summary
!
================
R4
----------------
interface Loopback40
ip address 40.40.40.40 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.40.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.30.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
variance 2
network 40.40.40.40 0.0.0.0
network 192.168.30.0 0.0.0.3
network 192.168.40.0 0.0.0.3
no auto-summary
!
=====================================================
В итоге 2 маршрута прилетают только на противоположностоящие роутеры.
Например:
R4#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.30.0/30 is subnetted, 1 subnets
C 192.168.30.0 is directly connected, FastEthernet0/1
20.0.0.0/32 is subnetted, 1 subnets
D 20.20.20.20 [90/158720] via 192.168.40.2, 00:30:55, FastEthernet0/0
[90/158720] via 192.168.30.1, 00:30:55, FastEthernet0/1
192.168.10.0/30 is subnetted, 1 subnets
D 192.168.10.0 [90/30720] via 192.168.40.2, 00:30:59, FastEthernet0/0
192.168.40.0/30 is subnetted, 1 subnets
C 192.168.40.0 is directly connected, FastEthernet0/0
192.168.20.0/30 is subnetted, 1 subnets
D 192.168.20.0 [90/30720] via 192.168.30.1, 00:30:55, FastEthernet0/1
40.0.0.0/32 is subnetted, 1 subnets
C 40.40.40.40 is directly connected, Loopback40
10.0.0.0/32 is subnetted, 1 subnets
D 10.10.10.10 [90/156160] via 192.168.40.2, 00:30:48, FastEthernet0/0
30.0.0.0/32 is subnetted, 1 subnets
D 30.30.30.30 [90/156160] via 192.168.30.1, 00:32:28, FastEthernet0/1
R4#
Хотя стоит VARIANCE 2.
Отключаю физику (сеть 192.168.40.0/30):
был
D 10.10.10.10 [90/156160] via 192.168.40.2, 00:00:08, FastEthernet0/0
стал
D 10.10.10.10 [90/161280] via 192.168.30.1, 00:00:04, FastEthernet0/1
156160*2 = 312320 < 161280
Т.е. как бы все ок с variance.
Но создается впечатление, что эта фича не работает.
В итоге получается:
R1 видит R3 c двух сторон
R2 видит R4 c двух сторон
R3 видит R1 c двух сторон
R4 видит R2 c двух сторон
-------------------------
R1 не видит R2 c двух сторон
ну и т.д.
В eigrp эквивалентных маршрутов для этих роутеров вообще нет (только противоположный роутер):
R4#sh ip ei top
IP-EIGRP Topology Table for AS(100)/ID(44.44.44.44)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.10.10.10/32, 1 successors, FD is 156160
via 192.168.40.2 (156160/128256), FastEthernet0/0
P 20.20.20.20/32, 2 successors, FD is 158720
via 192.168.30.1 (158720/156160), FastEthernet0/1
via 192.168.40.2 (158720/156160), FastEthernet0/0
P 30.30.30.30/32, 1 successors, FD is 156160
via 192.168.30.1 (156160/128256), FastEthernet0/1
P 40.40.40.40/32, 1 successors, FD is 128256
via Connected, Loopback40
P 192.168.40.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.10.0/30, 1 successors, FD is 30720
via 192.168.40.2 (30720/28160), FastEthernet0/0
P 192.168.30.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 192.168.20.0/30, 1 successors, FD is 30720
via 192.168.30.1 (30720/28160), FastEthernet0/1
R4#
Собираю на этих железках:
R4#sh ver
Cisco IOS Software, 1841 Software (C1841-ENTSERVICES-M), Version 12.4(12), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Fri 17-Nov-06 11:01 by prod_rel_team
Где клад зарыт? Куда копать?
Хотелось бы увидеть все loopback'и c 2х сторон так же как и 20.20.20.20 например.